aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2025-01-20 23:11:00 +0100
committerdec05eba <dec05eba@protonmail.com>2025-01-20 23:11:00 +0100
commit47ada4d79844d9a98d9689d0de0c92864e0fc372 (patch)
tree1325fd3061e78a194b3db0be848a06928fdacce9 /meson.build
parent92401d8bc8fa3cbc8017936eb1d18280199942e0 (diff)
Add option to save replay with controller (double-click share button), allow prime-run on wayland
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e0be1e7..1afd57b 100644
--- a/meson.build
+++ b/meson.build
@@ -38,6 +38,8 @@ src = [
'src/Overlay.cpp',
'src/GlobalHotkeysX11.cpp',
'src/GlobalHotkeysLinux.cpp',
+ 'src/GlobalHotkeysJoystick.cpp',
+ 'src/Hotplug.cpp',
'src/Rpc.cpp',
'src/main.cpp',
]
@@ -49,6 +51,9 @@ prefix = get_option('prefix')
datadir = get_option('datadir')
gsr_ui_resources_path = join_paths(prefix, datadir, 'gsr-ui')
+add_project_arguments('-DGSR_UI_VERSION="' + meson.project_version() + '"', language: ['c', 'cpp'])
+add_project_arguments('-DGSR_FLATPAK_VERSION="5.0.10"', language: ['c', 'cpp'])
+
executable(
meson.project_name(),
src,