aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2025-05-04 22:39:37 +0200
committerdec05eba <dec05eba@protonmail.com>2025-05-04 22:39:37 +0200
commit305c9df7acc140d1d4b723948b9f59e8282eea87 (patch)
tree3b57db37b0a8178b95f7db9694fc676d0f9c3287 /meson.build
parentd08ea692771caa8e385412c2f992089672773e30 (diff)
Add option to save temporary replay data on disk1.6.0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 2f991ed..254c5b5 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('gsr-ui', ['c', 'cpp'], version : '1.5.1', default_options : ['warning_level=2', 'cpp_std=c++17'], subproject_dir : 'depends')
+project('gsr-ui', ['c', 'cpp'], version : '1.6.0', default_options : ['warning_level=2', 'cpp_std=c++17'], subproject_dir : 'depends')
if get_option('buildtype') == 'debug'
add_project_arguments('-g3', language : ['c', 'cpp'])
@@ -32,6 +32,11 @@ src = [
'src/gui/GlobalSettingsPage.cpp',
'src/gui/GsrPage.cpp',
'src/gui/Subsection.cpp',
+ 'src/GlobalHotkeys/GlobalHotkeysX11.cpp',
+ 'src/GlobalHotkeys/GlobalHotkeysLinux.cpp',
+ 'src/GlobalHotkeys/GlobalHotkeysJoystick.cpp',
+ 'src/CursorTracker/CursorTrackerX11.cpp',
+ 'src/CursorTracker/CursorTrackerWayland.cpp',
'src/Utils.cpp',
'src/WindowUtils.cpp',
'src/RegionSelector.cpp',
@@ -39,11 +44,6 @@ src = [
'src/GsrInfo.cpp',
'src/Process.cpp',
'src/Overlay.cpp',
- 'src/GlobalHotkeys/GlobalHotkeysX11.cpp',
- 'src/GlobalHotkeys/GlobalHotkeysLinux.cpp',
- 'src/GlobalHotkeys/GlobalHotkeysJoystick.cpp',
- 'src/CursorTracker/CursorTrackerX11.cpp',
- 'src/CursorTracker/CursorTrackerWayland.cpp',
'src/AudioPlayer.cpp',
'src/Hotplug.cpp',
'src/Rpc.cpp',