aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-11-24 18:25:58 +0100
committerdec05eba <dec05eba@protonmail.com>2024-11-24 18:33:57 +0100
commit734280f3042a1b2d08764599d1decdee2d4d3132 (patch)
tree4f72eb3aee2f8a98c05e4554f137f6e296fb2018 /meson.build
parent56a7e558d290d168a906dba984f5051c1e327712 (diff)
Use linux /dev/input for global hotkeys instead of x11. This also works on wayland on any compositor
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ad3898d..056fea3 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,7 @@ src = [
'src/Process.cpp',
'src/Overlay.cpp',
'src/GlobalHotkeysX11.cpp',
+ 'src/GlobalHotkeysLinux.cpp',
'src/main.cpp',
]
@@ -65,10 +66,26 @@ executable(
dependencies : [dependency('x11')],
)
+executable(
+ 'gsr-global-hotkeys',
+ ['tools/gsr-global-hotkeys/main.c'],
+ install : true,
+ dependencies : [
+ dependency('libevdev'),
+ dependency('libudev'),
+ dependency('libinput'),
+ dependency('xkbcommon')
+ ],
+)
+
install_subdir('images', install_dir : gsr_ui_resources_path)
install_subdir('fonts', install_dir : gsr_ui_resources_path)
install_subdir('scripts', install_dir : gsr_ui_resources_path, install_mode : 'rwxr-xr-x')
if get_option('systemd') == true
install_data(files('extra/gpu-screen-recorder-ui.service'), install_dir : 'lib/systemd/user')
+endif
+
+if get_option('capabilities') == true
+ meson.add_install_script('meson_post_install.sh')
endif \ No newline at end of file