aboutsummaryrefslogtreecommitdiff
path: root/fuzzers/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantinos Sideris <sideris.konstantin@gmail.com>2018-06-11 21:02:27 +0300
committerHubert Chathi <hubert@uhoreg.ca>2018-10-12 16:22:03 -0400
commit4e94dfc7e057776b0d1aafbeb72c8dad7918d988 (patch)
treef78cea96a63f146b161c6feb6e96d3a047498354 /fuzzers/CMakeLists.txt
parentaf86a9a8b899eeb3c1c464cb0c54218acd788fa6 (diff)
Add CMake support
The library can now be installed using CMake v3.0+. Below is an example configuration. 1. Generate configuation cmake -H. -Bbuild -GNinja -DCMAKE_BUILD_TYPE=Release // The default profile. -DCMAKE_INSTALL_PREFIX=/usr/local/ -DBUILD_SHARED_LIBS=ON -DOLM_TESTS=1 -DOLM_FUZZERS=1 2. Build & install the targets cmake --build build --config Release --target install 3. Run the tests cd build/test && ctest . The library can also be used as a dependency with CMake using find_package(Olm::Olm REQUIRED) target_link_libraries(my_exe Olm::Olm) Signed-off-by: Konstantinos Sideris <sideris.konstantin@gmail.com>
Diffstat (limited to 'fuzzers/CMakeLists.txt')
-rw-r--r--fuzzers/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/fuzzers/CMakeLists.txt b/fuzzers/CMakeLists.txt
new file mode 100644
index 0000000..ec95b59
--- /dev/null
+++ b/fuzzers/CMakeLists.txt
@@ -0,0 +1,19 @@
+add_executable(fuzz_decode_message fuzz_decode_message.cpp)
+target_include_directories(fuzz_decode_message PRIVATE include)
+target_link_libraries(fuzz_decode_message Olm::Olm)
+
+add_executable(fuzz_decrypt fuzz_decrypt.cpp)
+target_include_directories(fuzz_decrypt PRIVATE include)
+target_link_libraries(fuzz_decrypt Olm::Olm)
+
+add_executable(fuzz_group_decrypt fuzz_group_decrypt.cpp)
+target_include_directories(fuzz_group_decrypt PRIVATE include)
+target_link_libraries(fuzz_group_decrypt Olm::Olm)
+
+add_executable(fuzz_unpickle_account fuzz_unpickle_account.cpp)
+target_link_libraries(fuzz_unpickle_account Olm::Olm)
+target_include_directories(fuzz_unpickle_account PRIVATE include)
+
+add_executable(fuzz_unpickle_session fuzz_unpickle_session.cpp)
+target_link_libraries(fuzz_unpickle_session Olm::Olm)
+target_include_directories(fuzz_unpickle_session PRIVATE include)