aboutsummaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorHubert Chathi <hubert@uhoreg.ca>2019-04-08 15:08:17 -0400
committerGitHub <noreply@github.com>2019-04-08 15:08:17 -0400
commit2a6400716c1e17b65507cd2a433192f81cd402df (patch)
treeeb034ad74fab1e337b422d387e8e9a8b62bfb098 /python/setup.py
parentfcfa5f12a4cd482973fdf03000af4a26a360dc2e (diff)
parent709687a7b56d6768831766459940b6f0bb078d85 (diff)
Merge branch 'master' into poljar/python-sas
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index 4b0deb1..5742fd9 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -22,6 +22,10 @@ setup(
packages=["olm"],
setup_requires=["cffi>=1.0.0"],
cffi_modules=["olm_build.py:ffibuilder"],
- install_requires=["cffi>=1.0.0", "future", "typing"],
+ install_requires=[
+ "cffi>=1.0.0",
+ "future",
+ "typing;python_version<'3.5'"
+ ],
zip_safe=False
)