aboutsummaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100644
index 0000000..4b0deb1
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,27 @@
+# -*- coding: utf-8 -*-
+
+import os
+from codecs import open
+
+from setuptools import setup
+
+here = os.path.abspath(os.path.dirname(__file__))
+
+about = {}
+with open(os.path.join(here, "olm", "__version__.py"), "r", "utf-8") as f:
+ exec(f.read(), about)
+
+setup(
+ name=about["__title__"],
+ version=about["__version__"],
+ description=about["__description__"],
+ author=about["__author__"],
+ author_email=about["__author_email__"],
+ url=about["__url__"],
+ license=about["__license__"],
+ packages=["olm"],
+ setup_requires=["cffi>=1.0.0"],
+ cffi_modules=["olm_build.py:ffibuilder"],
+ install_requires=["cffi>=1.0.0", "future", "typing"],
+ zip_safe=False
+)