aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2017-12-12 17:33:03 +0100
committerdec05eba <dec05eba@protonmail.com>2017-12-12 17:34:16 +0100
commitf3b7b7d34b3bf2b1be18914577c96b66dead379a (patch)
treef24a08256bc959929d51045eb49283fcab7e8b54 /CMakeLists.txt
parentcfe578ec12198d09a9a89a2e0b40bccaa06aa8ae (diff)
Download and extract missing dependencies from github
Using libcurl and libarchive
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96c4185..a636daa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,24 @@
-cmake_minimum_required(VERSION 3.8)
+cmake_minimum_required(VERSION 3.0.2)
project(sibs)
set(CMAKE_CXX_STANDARD 11)
set(SOURCE_FILES
+ external/xxhash.c
+ backend/ninja/Ninja.cpp
src/main.cpp
src/FileUtil.cpp
src/Conf.cpp
- external/xxhash.c backend/ninja/Ninja.cpp src/PkgConfig.cpp src/Exec.cpp src/GlobalLib.cpp)
+ src/PkgConfig.cpp
+ src/Exec.cpp
+ src/GlobalLib.cpp
+ src/curl.cpp
+ src/Archive.cpp)
-add_executable(sibs ${SOURCE_FILES}) \ No newline at end of file
+find_package(CURL REQUIRED)
+find_package(LibArchive REQUIRED)
+
+add_executable(sibs ${SOURCE_FILES})
+
+include_directories(${CURL_INCLUDE_DIR} ${LibArchive_INCLUDE_DIR})
+target_link_libraries(sibs ${CURL_LIBRARIES} ${LibArchive_LIBRARIES}) \ No newline at end of file