aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a58a3cd..a7cd470 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,10 +22,15 @@ set(SOURCE_FILES
depends/libninja/src/Ninja.cpp)
find_package(CURL REQUIRED)
-find_package(LibArchive REQUIRED)
-add_executable(sibs ${SOURCE_FILES})
+if(APPLE)
+ set(LibArchive_LIBRARIES "/usr/local/opt/libarchive/lib/libarchive.dylib")
+ set(LibArchive_INCLUDE_DIR "/usr/local/opt/libarchive/include")
+else()
+ find_package(LibArchive REQUIRED)
+endif()
+add_executable(sibs ${SOURCE_FILES})
include_directories(${CURL_INCLUDE_DIR} ${LibArchive_INCLUDE_DIR} "depends/libninja/include")
if(WIN32)