aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlexandru N. Onea <alexandru.onea@harman.com>2019-04-09 21:51:27 +0300
committerAlexandru N. Onea <alexandru.onea@harman.com>2019-04-09 22:16:23 +0300
commit52a7957cabc961d25b2eb765c34ca4e06844e197 (patch)
tree0fd89457d8fa85b7fd429f2c413f06eb354883bb /meson.build
parent891c04d70b30ed4533785469b8bd2f5d6c17a68c (diff)
Add check action to version-bump.sh; Activate checks
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dda722d..04edda5 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,13 @@ tinyalsa = library('tinyalsa',
version: meson.project_version(),
install: true)
+log_version = run_command(find_program('scripts/version-bump.sh'), 'check')
+if log_version.returncode() != 0
+ error(log_version.stderr())
+endif
+
+message(log_version.stdout())
+
# For use as a Meson subproject
tinyalsa_dep = declare_dependency(link_with: tinyalsa,
include_directories: include_directories('include'))