aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-09-01 18:48:57 +0200
committerdec05eba <dec05eba@protonmail.com>2024-09-01 18:48:57 +0200
commit4befa2afeb1dcd92a190b53c263af7beb3802646 (patch)
tree6547d524196e00e6a1f6f9fbda958242fb22b5ec /meson.build
parentde81da82709190535e5a88e6c048598528bd1ffd (diff)
Include default recording/replay/streaming images
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 90fa050..8f6f56b 100644
--- a/meson.build
+++ b/meson.build
@@ -18,9 +18,16 @@ dep = [
dependency('xfixes'),
]
+prefix = get_option('prefix')
+datadir = get_option('datadir')
+gsr_notify_resources_path = join_paths(prefix, datadir, 'gsr-notify')
+
executable(
meson.project_name(),
src,
install : true,
dependencies : dep,
-) \ No newline at end of file
+ cpp_args : '-DGSR_NOTIFY_RESOURCES_PATH="' + gsr_notify_resources_path + '"',
+)
+
+install_subdir('images', install_dir : gsr_notify_resources_path) \ No newline at end of file