aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-11-04 20:37:26 +0100
committerdec05eba <dec05eba@protonmail.com>2024-11-04 20:37:26 +0100
commit26a9e750dc6f1313413524cd97e60a94e25a56ec (patch)
treece651746328b2a2137d367d2affb82865cf0760f /meson.build
parent89512313b263c9b5250b8d51e5e6eb04d0ac43e7 (diff)
Add option to save replay/recording to a folder with the name of the game
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index edd90b8..e64b9dc 100644
--- a/meson.build
+++ b/meson.build
@@ -57,8 +57,16 @@ executable(
cpp_args : '-DGSR_UI_RESOURCES_PATH="' + gsr_ui_resources_path + '"',
)
+executable(
+ 'gsr-window-name',
+ ['gsr-window-name/main.c'],
+ install : true,
+ dependencies : [dependency('x11')],
+)
+
install_subdir('images', install_dir : gsr_ui_resources_path)
install_subdir('fonts', install_dir : gsr_ui_resources_path)
+install_subdir('scripts', install_dir : gsr_ui_resources_path, install_mode : 'rwxr-xr-x')
if get_option('systemd') == true
install_data(files('extra/gpu-screen-recorder-ui.service'), install_dir : 'lib/systemd/user')