aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2025-04-04 20:51:28 +0200
committerdec05eba <dec05eba@protonmail.com>2025-04-04 20:51:28 +0200
commit2e3adfc5100c4c273529d7e0ed1cba42f184395f (patch)
tree1342ecd7e0910c739739948d31114419ce22f1bd /meson.build
parent44f35f8f3b39892def66a2a0f15d3a261f0be778 (diff)
Add option to capture the focused monitor
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b522488..f458c88 100644
--- a/meson.build
+++ b/meson.build
@@ -42,12 +42,17 @@ src = [
'src/GlobalHotkeysX11.cpp',
'src/GlobalHotkeysLinux.cpp',
'src/GlobalHotkeysJoystick.cpp',
+ 'src/CursorTrackerX11.cpp',
+ 'src/CursorTrackerWayland.cpp',
'src/AudioPlayer.cpp',
'src/Hotplug.cpp',
'src/Rpc.cpp',
'src/main.cpp',
]
+subdir('protocol')
+src += protocol_src
+
mglpp_proj = subproject('mglpp')
mglpp_dep = mglpp_proj.get_variable('mglpp_dep')
@@ -71,6 +76,8 @@ executable(
dependency('xi'),
dependency('xcursor'),
dependency('libpulse-simple'),
+ dependency('libdrm'),
+ dependency('wayland-client'),
],
cpp_args : '-DGSR_UI_RESOURCES_PATH="' + gsr_ui_resources_path + '"',
)