aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-08-05 21:25:59 +0200
committerdec05eba <dec05eba@protonmail.com>2024-08-05 21:25:59 +0200
commitae1897cf2ce6a447b253ffa8489b5c016a23fb41 (patch)
tree660a14cd189ce93abd4a158c69a55abc2bf95700 /meson.build
parent041ee753b1253a2f66df0de6e8905774e2e33a77 (diff)
Resources path should use the same path as meson installed path
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 59a02e3..0b428f4 100644
--- a/meson.build
+++ b/meson.build
@@ -31,13 +31,16 @@ dep = [
mglpp_dep,
]
+prefix = get_option('prefix')
+datadir = get_option('datadir')
+gsr_overlay_resources_path = join_paths(prefix, datadir, 'gsr-overlay')
+
executable(
meson.project_name(),
src,
install : true,
dependencies : dep,
+ cpp_args : '-DGSR_OVERLAY_RESOURCES_PATH="' + gsr_overlay_resources_path + '"',
)
-prefix = get_option('prefix')
-datadir = get_option('datadir')
-install_subdir('images', install_dir : join_paths(prefix, datadir, 'gsr-overlay')) \ No newline at end of file
+install_subdir('images', install_dir : gsr_overlay_resources_path) \ No newline at end of file