aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-12-16 02:21:38 +0100
committerdec05eba <dec05eba@protonmail.com>2024-12-16 02:21:38 +0100
commitebd8c2726b8caac6adc00cf15c5631e51d05ba1f (patch)
treefb60d1908154aeec0ff6b568b269e97b9601d70b /meson.build
parent970d87975b01cd083749179df489477b94a35f41 (diff)
Rewrite linux global hotkey to not depend on any libraries (also allows it to work on non-systemd systems(?)), remove unused gsr-window-name
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 5 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 3b21a93..9aacae9 100644
--- a/meson.build
+++ b/meson.build
@@ -62,22 +62,13 @@ executable(
)
executable(
- 'gsr-window-name',
- ['tools/gsr-window-name/main.c'],
- install : true,
- dependencies : [dependency('x11')],
-)
-
-executable(
'gsr-global-hotkeys',
- ['tools/gsr-global-hotkeys/main.c'],
- install : true,
- dependencies : [
- dependency('libevdev'),
- dependency('libudev'),
- dependency('libinput'),
- dependency('xkbcommon')
+ [
+ 'tools/gsr-global-hotkeys/hotplug.c',
+ 'tools/gsr-global-hotkeys/keyboard_event.c',
+ 'tools/gsr-global-hotkeys/main.c'
],
+ install : true
)
install_subdir('images', install_dir : gsr_ui_resources_path)