aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2025-02-10 18:22:21 +0100
committerdec05eba <dec05eba@protonmail.com>2025-02-10 18:22:21 +0100
commitf4e44cbef5dbbc2a2b71e7b9b70ee72d30b7c6a6 (patch)
treefba7a409ad73abc4b233c9dfd960f014c2df6b69 /meson.build
parent3d6354c642244cde272c328a31c72a0adba54999 (diff)
Prepare for sound. Fix game name being gsr-ui on wayland in some cases when saving video when the ui is open
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ba3b7cd..fc2f4f4 100644
--- a/meson.build
+++ b/meson.build
@@ -39,6 +39,7 @@ src = [
'src/GlobalHotkeysX11.cpp',
'src/GlobalHotkeysLinux.cpp',
'src/GlobalHotkeysJoystick.cpp',
+ 'src/AudioPlayer.cpp',
'src/Hotplug.cpp',
'src/Rpc.cpp',
'src/main.cpp',
@@ -65,6 +66,7 @@ executable(
dependency('xfixes'),
dependency('xi'),
dependency('xcursor'),
+ dependency('libpulse-simple'),
],
cpp_args : '-DGSR_UI_RESOURCES_PATH="' + gsr_ui_resources_path + '"',
)