aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDamir Jelić <poljar@termina.org.uk>2019-04-28 08:53:19 +0200
committerDamir Jelić <poljar@termina.org.uk>2019-04-28 08:55:40 +0200
commit6eca9f1278e9874c9c6bb31555d164c376d264ed (patch)
treef5021b580aad53bde9d236a099b8edcf14268773 /CMakeLists.txt
parent992323c37cfa997939938281cb08f84ec8968a5b (diff)
cmake: Add the SAS functions to the CMake build.
Signed-off-by: Damir Jelić <poljar@termina.org.uk>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 390db27..6761295 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,7 @@ add_library(olm
src/session.cpp
src/utility.cpp
src/pk.cpp
+ src/sas.c
src/ed25519.c
src/error.c
@@ -79,6 +80,7 @@ install(FILES
${CMAKE_SOURCE_DIR}/include/olm/outbound_group_session.h
${CMAKE_SOURCE_DIR}/include/olm/inbound_group_session.h
${CMAKE_SOURCE_DIR}/include/olm/pk.h
+ ${CMAKE_SOURCE_DIR}/include/olm/sas.h
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/olm)
# Export the targets to a script.