aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHubert Chathi <hubert@uhoreg.ca>2020-10-29 16:24:46 -0400
committerHubert Chathi <hubert@uhoreg.ca>2020-10-29 16:26:06 -0400
commit8efa0ec17d8c262f9c3fd7603e8074f74a053708 (patch)
tree8d362f867fd93ea3e9df8bc41aba372c27904ffb /CMakeLists.txt
parentc5ab3ecbf272f0920b52226260a5d6045c1cc8b6 (diff)
Use current source directory in CMake. Thanks to Gorgurov Alexey.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5101631..0b049e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,11 +79,11 @@ install(TARGETS olm
# The exported target will be named Olm.
set_target_properties(olm PROPERTIES EXPORT_NAME Olm)
install(FILES
- ${CMAKE_SOURCE_DIR}/include/olm/olm.h
- ${CMAKE_SOURCE_DIR}/include/olm/outbound_group_session.h
- ${CMAKE_SOURCE_DIR}/include/olm/inbound_group_session.h
- ${CMAKE_SOURCE_DIR}/include/olm/pk.h
- ${CMAKE_SOURCE_DIR}/include/olm/sas.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/include/olm/olm.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/include/olm/outbound_group_session.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/include/olm/inbound_group_session.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/include/olm/pk.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/include/olm/sas.h
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/olm)
# Export the targets to a script.