aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Andreyev <aa13q@ya.ru>2019-06-27 16:48:44 +0300
committerHubert Chathi <hubert@uhoreg.ca>2019-07-03 15:24:13 -0400
commitaa0c9ab6b51d182cb78ab4cc75c81c0054765bde (patch)
tree04daa02740434858e253a1cb7d0e37b4a61b9d78 /CMakeLists.txt
parentebd3ba6cc17862aefc9cb3299d60aeae953cc143 (diff)
CMakeLists.txt: add env vars to target_include_directories
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7339f5..da5baee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,8 +50,8 @@ add_library(Olm::Olm ALIAS olm)
target_include_directories(olm
PUBLIC
- $<BUILD_INTERFACE:${CMAKE_SOURCE_DIR}/include>
- $<INSTALL_INTERFACE:include>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
PRIVATE
${CMAKE_CURRENT_SOURCE_DIR}/lib)