aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHubert Chathi <hubert@uhoreg.ca>2018-10-22 14:15:19 -0400
committerHubert Chathi <hubert@uhoreg.ca>2018-10-23 12:24:49 -0400
commitefbe061153f233fc4ef8e67ac7d5507c6ddb253e (patch)
tree9496ef0631f366a88e4a058aaccdc863c5e8105a /CMakeLists.txt
parent238c512d203d22e93b2c30630b12f4269175bb85 (diff)
default to building as a shared library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19e1a86..cd85427 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,7 @@ cmake_minimum_required(VERSION 3.1)
project(olm VERSION 2.3.0 LANGUAGES CXX C)
option(OLM_TESTS "Build tests" ON)
+option(BUILD_SHARED_LIBS "Build as a shared library" ON)
add_definitions(-DOLMLIB_VERSION_MAJOR=${PROJECT_VERSION_MAJOR})
add_definitions(-DOLMLIB_VERSION_MINOR=${PROJECT_VERSION_MINOR})