aboutsummaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2020-11-05 01:45:06 +0100
committerdec05eba <dec05eba@protonmail.com>2020-11-05 01:45:06 +0100
commit2a8202e74846d191a321cca1202175af9db6107d (patch)
treea6f455caf07da1186851f343a237a4c4e4484f46 /python/setup.py
parent8efa0ec17d8c262f9c3fd7603e8074f74a053708 (diff)
Convert to sibs projectHEADmaster
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py31
1 files changed, 0 insertions, 31 deletions
diff --git a/python/setup.py b/python/setup.py
deleted file mode 100644
index 5742fd9..0000000
--- a/python/setup.py
+++ /dev/null
@@ -1,31 +0,0 @@
-# -*- coding: utf-8 -*-
-
-import os
-from codecs import open
-
-from setuptools import setup
-
-here = os.path.abspath(os.path.dirname(__file__))
-
-about = {}
-with open(os.path.join(here, "olm", "__version__.py"), "r", "utf-8") as f:
- exec(f.read(), about)
-
-setup(
- name=about["__title__"],
- version=about["__version__"],
- description=about["__description__"],
- author=about["__author__"],
- author_email=about["__author_email__"],
- url=about["__url__"],
- license=about["__license__"],
- packages=["olm"],
- setup_requires=["cffi>=1.0.0"],
- cffi_modules=["olm_build.py:ffibuilder"],
- install_requires=[
- "cffi>=1.0.0",
- "future",
- "typing;python_version<'3.5'"
- ],
- zip_safe=False
-)