aboutsummaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index 4b0deb1..5742fd9 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -22,6 +22,10 @@ setup(
packages=["olm"],
setup_requires=["cffi>=1.0.0"],
cffi_modules=["olm_build.py:ffibuilder"],
- install_requires=["cffi>=1.0.0", "future", "typing"],
+ install_requires=[
+ "cffi>=1.0.0",
+ "future",
+ "typing;python_version<'3.5'"
+ ],
zip_safe=False
)