aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2025-04-18 12:55:00 +0200
committerdec05eba <dec05eba@protonmail.com>2025-04-18 12:55:00 +0200
commit26c56565cc0573ce23eb8d172a6765bce1f657ce (patch)
treec4ceaacd336946acec12af5f2c5c4d2a78370744 /meson.build
parent506c271eafec23bf469caf6c29431191fa885e58 (diff)
Separate glx and egl from window system to prepare for wayland
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5f20c58..88ebbd8 100644
--- a/meson.build
+++ b/meson.build
@@ -28,6 +28,10 @@ src = [
'src/gl.c',
]
+src += [
+ 'src/window/wayland.c',
+]
+
project_headers = [
'include/mgl/graphics/rectangle.h',
'include/mgl/graphics/sprite.h',
@@ -64,6 +68,11 @@ dep = [
cc.find_library('m'),
]
+dep += [
+ dependency('wayland-client'),
+ dependency('wayland-egl'),
+]
+
public_headers = include_directories('include')
project_target = static_library(