aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build30
1 files changed, 3 insertions, 27 deletions
diff --git a/meson.build b/meson.build
index eecc7d8..58a280a 100644
--- a/meson.build
+++ b/meson.build
@@ -18,6 +18,9 @@ src = [
'src/graphics/text.c',
'src/graphics/shader.c',
'src/graphics/rectangle.c',
+ 'src/graphics/backend/graphics.c',
+ 'src/graphics/backend/glx.c',
+ 'src/graphics/backend/egl.c',
'src/system/fileutils.c',
'src/system/utf8.c',
'src/system/clock.c',
@@ -35,33 +38,6 @@ src += [
subdir('protocol')
src += protocol_src
-project_headers = [
- 'include/mgl/graphics/rectangle.h',
- 'include/mgl/graphics/sprite.h',
- 'include/mgl/graphics/texture.h',
- 'include/mgl/graphics/font_char_map.h',
- 'include/mgl/graphics/font.h',
- 'include/mgl/graphics/image.h',
- 'include/mgl/graphics/shader.h',
- 'include/mgl/graphics/primitive_type.h',
- 'include/mgl/graphics/vertex.h',
- 'include/mgl/graphics/vertex_buffer.h',
- 'include/mgl/graphics/font_glyph.h',
- 'include/mgl/graphics/color.h',
- 'include/mgl/graphics/text.h',
- 'include/mgl/system/fileutils.h',
- 'include/mgl/system/clock.h',
- 'include/mgl/system/vec.h',
- 'include/mgl/system/utf8.h',
- 'include/mgl/gl.h',
- 'include/mgl/window/event.h',
- 'include/mgl/window/mouse_button.h',
- 'include/mgl/window/window.h',
- 'include/mgl/window/key.h',
- 'include/mgl/gl_macro.h',
- 'include/mgl/mgl.h',
-]
-
cc = meson.get_compiler('c')
dep = [
dependency('x11'),