aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2018-01-02 20:08:48 +0100
committerdec05eba <dec05eba@protonmail.com>2018-01-02 20:10:53 +0100
commitfb18bd235bc716963c72c1dd6358176cb50516ae (patch)
treecda9e38546c0d2a738dd9e2adc7f984d431e6beb /CMakeLists.txt
parent8ac9ddf460cc4c1b2972df1069128fb615b31042 (diff)
Add missing return statement causing segfault
Added compile flags to give error when missing return statement
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 567d534..704b4c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,3 +23,4 @@ add_executable(sibs ${SOURCE_FILES})
include_directories(${CURL_INCLUDE_DIR} ${LibArchive_INCLUDE_DIR})
target_link_libraries(sibs ${CURL_LIBRARIES} ${LibArchive_LIBRARIES})
+target_compile_options(sibs PRIVATE -Wall -Wextra -Werror=return-type -fdiagnostics-show-option -fexceptions)