aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBhalchandra Gajare <gajare@codeaurora.org>2019-06-19 15:30:42 -0700
committerRohit kumar <rohitkr@codeaurora.org>2020-02-07 12:53:00 +0530
commite7c627dd74f5d43439792491c291564e298cbb10 (patch)
tree3d63ee71cbd1bf6d51f0be517a27073fe00c9bf0 /CMakeLists.txt
parent986b8e338782a4c8aab83e626949ed5457eb5b69 (diff)
tinyalsa: add support for mixer plugins
Update the mixer framework to support plugins. Add ability for physical card to have either kernel registered mixer controls or plugin registered mixer control or both. Split mixer controls into two groups, one for kernel registered (hw_grp) and the other for plugin registered (virtual_grp). Signed-off-by: Rohit kumar <rohitkr@codeaurora.org> Signed-off-by: Bhalchandra Gajare <gajare@codeaurora.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77227d5..f4db226 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,9 @@ set (SRCS
"src/pcm_hw.c"
"src/pcm_plugin.c"
"src/snd_card_plugin.c"
- "src/mixer.c")
+ "src/mixer.c"
+ "src/mixer_hw.c"
+ "src/mixer_plugin.c")
add_library("tinyalsa" ${HDRS} ${SRCS})
target_compile_options("tinyalsa" PRIVATE -Wall -Wextra -Werror -Wfatal-errors ${plugin_opt})