aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Wilson <simonrules@users.noreply.github.com>2020-09-21 10:15:11 -0600
committerGitHub <noreply@github.com>2020-09-21 10:15:11 -0600
commiteab1a8acdd13f52f084c91201f7784ee6bed86d1 (patch)
tree6c4f485d9832dcdbcefceedf35fbc3621de1d0ad /CMakeLists.txt
parent618a7e28a86dcec74ce02580190f6ad173bf7719 (diff)
parent7310073cb7a3e314140ebc66e5a58c94f0b6b58a (diff)
Merge pull request #182 from ericriff/eriff/fix-cmakelist
Fix error when building with -DTINYALSA_BUILD_UTILS=OFF
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acd4807..84de10b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,7 +69,10 @@ foreach(UTIL IN LISTS TINYALSA_UTILS)
add_executable("${UTIL}" "utils/${UTIL}.c")
target_link_libraries("${UTIL}" PRIVATE "tinyalsa")
endforeach()
-target_link_libraries("tinywavinfo" PRIVATE m)
+
+if(TINYALSA_BUILD_UTILS)
+ target_link_libraries("tinywavinfo" PRIVATE m)
+endif()
# Add C warning flags
include(CheckCCompilerFlag)