aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTaylor Holberton <taylorcholberton@gmail.com>2016-10-01 22:37:39 -0400
committerTaylor Holberton <taylorcholberton@gmail.com>2016-10-01 22:37:39 -0400
commita2c8dc2bf6108311746f1b3e3e8ac02a465d762f (patch)
tree57308ac73c045286f92f4007973841506fd2b63d /debian/rules
parent7a753ead88c10d00120405daaefaf2cd8286a887 (diff)
adding debian files
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..07f8f21
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#DH_VERBOSE = 1
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+PREPROCESS_FILES := $(wildcard debian/*.in)
+
+$(PREPROCESS_FILES:.in=): %: %.in
+ sed 's,/@DEB_HOST_MULTIARCH@,$(DEB_HOST_MULTIARCH:%=/%),g' $< > $@
+
+.PHONY: override_dh_auto_clean
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf $(PREPROCESS_FILES:.in=)
+
+.PHONY: override_dh_shlibdeps
+override_dh_shlibdeps:
+ dh_shlibdeps -l$(shell pwd)/src
+
+.PHONY: override_dh_auto_install
+override_dh_auto_install: $(PREPROCESS_FILES:.in=)
+ dh_auto_install -- PREFIX=/usr
+
+.PHONY: override_dh_auto_test
+override_dh_auto_test:
+
+%:
+ dh $@
+