aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTaylor Holberton <taylorcholberton@gmail.com>2018-12-17 08:53:43 -0500
committerGitHub <noreply@github.com>2018-12-17 08:53:43 -0500
commita4ac5f5a3b09f3d646ad8e777f43810a8c5ba3da (patch)
treea830e853561fb5215850b1de748d23f7fe4562c2 /meson.build
parentc3cdfc490bf902e45e250702a2106c6d2a5ea5ab (diff)
parent443542bfd30318ddbe3d1c7c029f90386b541347 (diff)
Merge pull request #121 from tp-m/meson-extract-version-from-header
meson: extract project version from header file and version .so
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e09a8be..67607a1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,10 +1,13 @@
-project ('tinyalsa', 'c', version : '1.1.1', meson_version : '>= 0.48.0')
+project ('tinyalsa', 'c',
+ version : run_command(find_program('version.py')).stdout().strip(),
+ meson_version : '>= 0.48.0')
tinyalsa_includes = include_directories('.', 'include')
tinyalsa = library('tinyalsa',
'src/mixer.c', 'src/pcm.c',
include_directories: tinyalsa_includes,
+ version: meson.project_version(),
install: true)
# For use as a Meson subproject