aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2025-03-10 18:07:46 +0100
committerdec05eba <dec05eba@protonmail.com>2025-03-10 18:07:46 +0100
commit69ac43bc5136c1e6638e367280cf4be85322fb1d (patch)
tree2f144092c403e84c8416e7f567e65ec07964fbed /meson.build
parent2a8a9d56106763339e417d39d0176770124424cd (diff)
Fix rapidjson dependency using system rapidjson instead of embedded rapidjsonHEADmaster
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 97ee65f..a675ac8 100644
--- a/meson.build
+++ b/meson.build
@@ -75,6 +75,9 @@ mglpp_dep = mglpp_proj.get_variable('mglpp_dep')
jsoncpp_proj = subproject('jsoncpp')
jsoncpp_dep = jsoncpp_proj.get_variable('jsoncpp_dep')
+rapidjson_proj = subproject('rapidjson')
+rapidjson_dep = rapidjson_proj.get_variable('rapidjson_dep')
+
html_parser_proj = subproject('html-parser')
html_parser_dep = html_parser_proj.get_variable('html_parser_dep')
@@ -96,6 +99,7 @@ executable(
dependencies : [
mglpp_dep,
jsoncpp_dep,
+ rapidjson_dep,
html_parser_dep,
html_search_dep,
dependency('threads'),