aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c3f8d7a..a2446a1 100644
--- a/meson.build
+++ b/meson.build
@@ -85,7 +85,9 @@ prefix = get_option('prefix')
datadir = get_option('datadir')
qm_resources_path = join_paths(prefix, datadir, 'quickmedia')
-add_project_arguments('-march=native', language: ['c', 'cpp'])
+if get_option('native_arch') == true
+ add_project_arguments('-march=native', language: ['c', 'cpp'])
+endif
executable(
meson.project_name(),
@@ -123,7 +125,9 @@ install_data(files('boards.json'), install_dir : qm_resources_path)
install_data(files('example-config.json'), install_dir : qm_resources_path)
install_data(files('README.md'), install_dir : qm_resources_path)
-install_symlink('qm', install_dir : join_paths(prefix, 'bin'), pointing_to: join_paths(prefix, 'bin', meson.project_name()))
+if get_option('install_symlink') == true
+ install_symlink('qm', install_dir : join_paths(prefix, 'bin'), pointing_to: join_paths(prefix, 'bin', meson.project_name()))
+endif
if get_option('install_emoji') == true
meson.add_install_script('meson_post_install.sh')