aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-06-18 21:39:23 +0200
committerdec05eba <dec05eba@protonmail.com>2024-06-18 21:39:23 +0200
commit26750f320fcb19fd5fa199bc935d7f5b0ea13c55 (patch)
tree3736744889224afd5c6e0847188e688632240441 /meson.build
parent7bbdd0735ddf57e84c29d5b181b04a9efccc7aca (diff)
Update systray icon cache and desktop database after install
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 96936fc..cdfc095 100644
--- a/meson.build
+++ b/meson.build
@@ -26,6 +26,10 @@ dep = [
executable('gpu-screen-recorder-gtk', src, dependencies : dep, install : true)
prefix = get_option('prefix')
-install_data(files('gpu-screen-recorder-gtk.desktop'), install_dir : join_paths(prefix, 'share/applications'))
-install_data(files('com.dec05eba.gpu_screen_recorder.appdata.xml'), install_dir : join_paths(prefix, 'share/metainfo'))
-install_subdir('icons/hicolor', install_dir : join_paths(prefix, 'share/icons'))
+datadir = get_option('datadir')
+install_data(files('gpu-screen-recorder-gtk.desktop'), install_dir : join_paths(prefix, datadir, 'applications'))
+install_data(files('com.dec05eba.gpu_screen_recorder.appdata.xml'), install_dir : join_paths(prefix, datadir, 'metainfo'))
+install_subdir('icons/hicolor', install_dir : join_paths(prefix, datadir, 'icons'))
+
+gnome = import('gnome')
+gnome.post_install(gtk_update_icon_cache : true, update_desktop_database : true) \ No newline at end of file