aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Rusakov <Alexey.Rusakov@pm.me>2019-10-11 00:01:29 +0000
committerHubert Chathi <hubert@uhoreg.ca>2019-10-23 16:48:14 -0400
commitbaaf00266314487f831726d7cb34ee2649f99e22 (patch)
tree2c092126318a7cd31f817ae90e4065f916bba638 /CMakeLists.txt
parent6753595300767dd70150831dbbe6f92d64e75038 (diff)
CMakeLists.txt: export include directories in install(TARGETS)
Without that, if olm is installed to a non-standard location, the user code might run CMake configuration fine but further building will fail. Signed-off-by: Alexey Rusakov <Alexey.Rusakov@pm.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c87f7b9..b831d03 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,9 @@ set(INSTALL_CONFIGDIR ${CMAKE_INSTALL_LIBDIR}/cmake/Olm)
install(TARGETS olm
EXPORT olm-targets
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+)
# The exported target will be named Olm.
set_target_properties(olm PROPERTIES EXPORT_NAME Olm)