aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authordec05eba <dec05eba@protonmail.com>2024-06-11 23:18:48 +0200
committerdec05eba <dec05eba@protonmail.com>2024-06-11 23:18:48 +0200
commit30ab9d789a351eda24171cf358c52a94791f746f (patch)
treef904c21c63b2e7b6606a03c5d82083f49fce7c3e /meson.build
parent3a637aabe936ae8348c71ea8bbce79effdb0d74b (diff)
Install files: respect prefix
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 6afc53e..96936fc 100644
--- a/meson.build
+++ b/meson.build
@@ -25,7 +25,7 @@ dep = [
executable('gpu-screen-recorder-gtk', src, dependencies : dep, install : true)
-install_data(files('gpu-screen-recorder-gtk.desktop'), install_dir : '/usr/share/applications')
-install_data(files('com.dec05eba.gpu_screen_recorder.appdata.xml'), install_dir : '/usr/share/metainfo')
-
-install_subdir('icons/hicolor', install_dir : '/usr/share/icons')
+prefix = get_option('prefix')
+install_data(files('gpu-screen-recorder-gtk.desktop'), install_dir : join_paths(prefix, 'share/applications'))
+install_data(files('com.dec05eba.gpu_screen_recorder.appdata.xml'), install_dir : join_paths(prefix, 'share/metainfo'))
+install_subdir('icons/hicolor', install_dir : join_paths(prefix, 'share/icons'))