aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
new file mode 100644
index 0000000..bbdccba
--- /dev/null
+++ b/protocol/meson.build
@@ -0,0 +1,25 @@
+wayland_scanner = dependency('wayland-scanner', native: true)
+wayland_scanner_path = wayland_scanner.get_variable(pkgconfig: 'wayland_scanner')
+wayland_scanner_prog = find_program(wayland_scanner_path, native: true)
+
+wayland_scanner_code = generator(
+ wayland_scanner_prog,
+ output: '@BASENAME@-protocol.c',
+ arguments: ['private-code', '@INPUT@', '@OUTPUT@'],
+)
+
+wayland_scanner_client = generator(
+ wayland_scanner_prog,
+ output: '@BASENAME@-client-protocol.h',
+ arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
+)
+
+protocols = [
+ 'xdg-output-unstable-v1.xml',
+]
+
+protocol_src = []
+foreach xml : protocols
+ protocol_src += wayland_scanner_code.process(xml)
+ protocol_src += wayland_scanner_client.process(xml)
+endforeach