aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim Schumacher <timschumi@gmx.de>2024-08-18 10:42:19 +0200
committerdec05eba <dec05eba@protonmail.com>2024-08-18 11:11:07 +0200
commit6b8e547737afa8e75eb3a92dc5d3f1d5ece06c91 (patch)
tree6f58f2067c7de4f807ec66cf12b4e41e55967c3a /meson.build
parentfa4317a9ea9bfd43e0ed92fc0191f157b22ccd1e (diff)
Don't install files using absolute paths
Also, move gsr-nvidia.conf to /lib/modprobe.d, which is the intended location for installed packages.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f1c93da..dcf1313 100644
--- a/meson.build
+++ b/meson.build
@@ -72,7 +72,7 @@ executable('gsr-kms-server', 'kms/server/kms_server.c', dependencies : dependenc
executable('gpu-screen-recorder', src, dependencies : dep, install : true)
if get_option('systemd') == true
- install_data(files('extra/gpu-screen-recorder.service'), install_dir : '/usr/lib/systemd/user')
+ install_data(files('extra/gpu-screen-recorder.service'), install_dir : 'lib/systemd/user')
endif
if get_option('capabilities') == true
@@ -80,5 +80,5 @@ if get_option('capabilities') == true
endif
if get_option('nvidia_suspend_fix') == true
- install_data(files('extra/gsr-nvidia.conf'), install_dir : '/etc/modprobe.d')
+ install_data(files('extra/gsr-nvidia.conf'), install_dir : 'lib/modprobe.d')
endif